CVE-2026-76646
7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Summary
A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition.
Older unsupported versions may also be affected.
Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.
Affected Software
| Vendor | Product | Version Range | Status |
|---|---|---|---|
| Apache Software Foundation | Apache MyFaces | 2.2.0-beta <= 2.2.15 | affected |
| Apache Software Foundation | Apache MyFaces | 2.3.0 | affected |
| Apache Software Foundation | Apache MyFaces | 2.3-next-M1 <= 2.3-next-M8 | affected |
| Apache Software Foundation | Apache MyFaces | 2.3.1 <= 2.3.11 | affected |
| Apache Software Foundation | Apache MyFaces | 3.0.0 <= 3.0.3 | affected |
| Apache Software Foundation | Apache MyFaces | 4.0.0 <= 4.0.3 | affected |
| Apache Software Foundation | Apache MyFaces | 4.1.0 <= 4.1.3 | affected |
Weaknesses
- CWE-400: CWE-400 Uncontrolled Resource Consumption
ADP Enrichment
CVE Program Container
Additional References
CISA ADP Vulnrichment
- SSVC:
- Exploitation: none
- Automatable: yes
- Technical Impact: partial
References
Feedback
Was this page helpful?
Glad to hear it! Please tell us how we can improve.
Sorry to hear that. Please tell us how we can improve.